OpenBCM V1.07b6_bn2 (Linux)

Packet Radio Mailbox

NB1BKM

[Box OBB]

 Login: IN1BKM





  
DNS205 > LINUX    29.10.08 10:04l 54 Lines 2533 Bytes #999 (0) @ DEU
BID : 61690_BX0BIW
Read: HF1BKM L66BPH BL1AIB OW1BKM KW1BKM MZ1AIB ES1MBL ES1FAI IN1BKM RN1NMB
Read: DAF999
Subj: Neue Probleme mit AX.25 unter Linux
Path: NB1BKM<AS1BOX<DOK001<D2BOX<DBQ213<DP0RBL<BX1RBL<BX0RBL<CT0BOX<BX0BIW
Sent: 081028/2345Z @:BX0BIW.#OL.O.DLNET.DEU.EU #:61690 [BIW JO71DD] $:61690_BX0
From: DNS205@BX0BIW.#OL.O.DLNET.DEU.EU
To  : LINUX@DEU

Hallo Leute,

es gibt Neuigkeiten in Sachen Linux und AX.25, leider aber auch neue
Probleme.
Unter dem neueren Kernel 2.6.24 von Debian Etch'n'half habe ich AX.25 nicht
zum Laufen bekommen. Es gibt immer wieder dieselben Fehlermeldungen, bei
denen mir niemand helfen kann.
Ich habe es nun noch mal mit dem Standardkernel 2.6.18 probiert und hatte
damit mehr Erfolg. Die Fehlermeldungen kommen nicht mehr und mit sethdlc
konnte ich schon den Port monitoren (sethdlc -i bcfs0). Der Versuch, mittels
call eine Verbindung aufzubauen, schlug aber immer fehl:

call cb25 cb0pir
axconfig: port cb25 not active
call: no AX.25 port data configured

Häää? Irgendwann bin ich drauf gekommen, das die Dokumentationen - selbst
die Manpages - eigentlich für die Katz' sind, weil dort entweder falsche
Dinge dringe stehen oder manches einfach fehlt.
Es fehlt z.B. die Angabe, das man beim Start des Interfaces mit ifconfig
zwingend eine IP-Adresse angeben muss - egal ob man über AX.25 TCP/IP machen
will oder nicht. Danach funktionierte es jedenfalls, zumindest die genannten
Fehlermeldungen kamen nicht mehr.
Die in den meisten Beschreibungen genannten Befehle insmod funktionieren
nicht mehr, man muss sie durch modprobe ersetzen. So gut wie überall findet
man als Devicename für den Baycom-Treiber bc0, bc1 etc., was aber nicht mehr
stimmt. Es gibt verschiedene Treiber und entsprechend verschiedene Namen:
Für den Fall des meist verwendeten Treibers baycom_ser_fdx heisst das Device
nun bcfs0 etc.
Ebenso widersprüchliche Angaben findet man für die AX.25-Parameter, die man
mit sethdlc -a -i bcfs0 ... festlegen kann. Teilweise ist z.B. für TXD von
Angabe in 10ms-Schritten die Rede, in Wirklichkeit muss man die Werte aber
in ms angeben.
Der Erfolg sieht derzeit so aus: Mit sethdlc kann ich den Port monitoren,
ebenso mit dem Befehl listen. Versuche ich aber, mit call eine Verbindung
aufzubauen, heisst es nur:

call cb25 cb0pir
GW4PTS AX.25 Connect v1.11
Trying...

Das war es dann. Offenbar sendet die Funke auch (ich sehe es nur an der
Funke, kann es jedoch nicht überprüfen), aber der Digi hört nicht bzw.
wertet das Signal nicht aus. Mit demselben Modem, aber am alten DOS-Rechner,
funktioniert es jedoch.
Hat jemand eine Ahnung, woran das noch liegen könnte? Ich bilde mir ein, die
Parameter ganz brauchbar gesetzt zu haben. Egal welchen Digi ich rufe, es
scheint nichts zu passieren... Wohl gemerkt, der Empfang klappt. Ideen?

vy bst 55+73s de Jan DNS205 aus Heidenau JO60WX


Lese vorherige Mail | Lese naechste Mail


 17.10.2019 07:45:32lZurueck Nach oben